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Eagle Point Solution to a Frequently Asked Question

How to export a plant database to Excel and import it into the Quantity Takeoff database

Summary:

This document walks you through the process exporting a plant database from the Plant Database module to a Microsoft Excel
spreadsheet and then importing the spreadsheet into the Quantity Takeoff database.

Product: Eagle Point Software™ 2001
Release: 2001 Q1 or 1.1.0 and greater
Platform: All

Related documents:

The tips, solutions and suggestions contained in Eagle Point Solution Papers, any Eagle Point Technical Assistance Document or
given by an Eagle Point Technical Assistance Representative are suggested for use at your own risk. Document contents are
subject to change without notice. No warranty of any kind, expressed or implied, is made with respect to such tips, solutions, and
suggestions except as may be expressly stated in the licensing agreement or other contractual document, including, without
limitation, any warranty of merchantability of fithess for a particular purpose. In no event is Eagle Point Software Corporation liable
for incidental or consequential damages in connection with or arising out of the use of such tips, solutions and suggestions.

AutoCAD is a registered trademark of Autodesk, Inc. MicroStation is a registered trademark of Bentley Systems, Inc. All other
product names are trademarks of their respective holders.

As always, should you have any questions regarding any phase of installation, contact Eagle Point Technical Assistance at
(800) 477-0909.

1. From the main Eagle Point toolbar select Products > Plant Database.

The plant database tool bar displays.

Plant Database M=

Data “iew Records Browze CAD Link
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2. Select the Data pull-down menu > Display.

The Plant Data dialog box displays.
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Scientific Mame Common Mame Code Mame -
A zoientific Mame A, caommon Mame code Hame _
Abelia grandiflara [alozsy abelia Abara

Ahies amabiliz Silver fir Aham

Ahies concolor "W hite fir Ahcaon

Abiez grandis [arand fir Abgrs

Ahies laziocarpa Subalpine fir Ahla

Ahies magnifica Fed fir Ahbma

Ahies procera Mable fir Ahbpr

Acacia conztricta “w'hite thorm acacia Acca

Acacia farmesiana Sweet acacia Acta

Acacia gredai Cat claw Acaar

Acacia redolens Arcacia Aore

Acacia stenophylla Shoestring acacia Azt

Acalvpha wilkeziana Copper leaf Ao ;I

1] 1161

Exit |

Select the plant names you wish to export to QTO. This can be done by holding down the
CTRL button on the keyboard and selecting the plants with a left mouse click, or you can

simply click on the Select All icon.

The Select All icon highlights all of the plants in the Plant Data dialog box.

[

Select the Data pull-down menu > Export to name file.

You are prompted for a name and location of this file.

Type in a name and click on Save.

Launch the Excel program.

In Excel, select the File pull-down menu > Open.

Use the Windows browser to find the location of the .nam file that was exported. You will

need to change the file of type to (all files) to display the name file.

Highlight the .nam file and click on Open.

The Text Import from Excel wizard displays.




Text Import Wizard - Step 1 of 3
The Text \Wizard has determined that your data is Delimited.
If this is correct, choose Mext, or choose the Data Type that best describes your data,

Criginal data type

Choose the file type that best describes your daka:

{+ Delimited - Characters such as commas o tabs separate each field.
(" Fixed width - Fields are aligned in columns with spaces bebween each field.

Skart imnpork ak pow: 1 3: File Origin: |'-.-'-.-'in|:||:-ws (AMSI) j

Preview of file CHWINNTIPROFILESY StudentiDeskiop) Test 1.narm.

zcientific Hame@d common Hame@code Hame -

belia grandiflora@slos=sy abelia@ibgra

bie=s amabili=@51lver fir@Abam

biez concolor@White fir@Aboon

bies grandis@Grand fir@ibgrs
=1 oA ol ] D1lLe

1Abla ﬂ

Zancel Finish |
10. Select the Delimited radio button and click on Next.
Step 2 of the wizard displays.
Text Import Wizard - Step 2 of 3 [ 2]

This screen lets vou set the delimiters your daka conkains, Y¥ou can see
b wour ket is affected in the preview below,

Delimiters
v Tah [ Semicolon [ Comma

[ Space W Cther: l@_| Text Qualifier: " il

[ Treat consecutive delimiters as ane

Data preview

zcientific Hame A common Hame pode Hame -
belia grandiflora [Glossy abelia Abgra

bie=s amabili= Silver fir bam

bie=s concolor White fir boon

bie=s grandi=s Grand fir

Kl I
Zancel < Back | Mexk = | Einish |

11. Select the Other check box and type @ in the available edit box. Click on Finish.

The file imports.



12. Select all columns.
13. Select the Format pull-down menu > Column > Auto fit selection.

This displays all of the information in the excel fields. The only information you need is the
Scientific Name or Common Name.

14. Delete the other two columns by selecting the column header and clicking on Delete.
You will now add the necessary columns headers for the Quantity Takeoff imports.

15. Highlight row number one, right mouse click and select Insert.
This creates a blank column on the top so the headers can be added. The necessary fields for
Quantity Takeoff are Description, Item ID, CSI Division, Units of Measure, Unit Cost 1, Unit Cost

2 and Plant Size. The column header for the Scientific Name or Common Name is Description.

16. Add the rest of the column headers (order doesn’t matter as the import allows you to
specify the order in which the columns are imported).

Excel example:

F& | =]

A | B [¢c] Db | E [ FE | 6 |

Description ltern [d TSl Planting size | Unit cost 1 Unit cost 2 Unit of measure

& scientific Mame

Abelia grandiflora

=Wk —

Mhicas armahilic

Populating the Item ID number fields

1. Typein an 8-character alpha or numeric item ID number in the cell below the Item ID
number header, e.g. 10000010.

2. Inthe next row down, type in the next number in sequence, e.g. 10000020.

You will want to space the numbers out so that you will have the ability to add items in between at
a later time.

w

To get the numbers to automatically populate the cells in the rest of the column, select the
two cells already populated.

Example of highlighted cells:
e oy —

A B |
Description ltern Id €
A scientific Name 10000010
Abelia grandiflora
Abies amabilis
Abies concolar
Ahies grandis

o e o

mlio o ool o me -



A [ B |

—
e ol el

M

Description ltern 1d | C
A scientific Narme 10000010
Abelia grandiflora 10000020
Abies amabilis 10000030
Abies concolor 10000040
Abies grandis 10000050

Abies lasiocarpa 10000060
Abies magnifica 10000070
Abies pracera 10000050
Acacia constricta 10000090
Acacia farnesiana 10000100
Acacia gregyi 10000110
Acacia redolens 10000120
Acacia stenophylla | 10000130
Acalypha wilkesiana | 10000140

4. Place your cursor on the grip that is located in the lower right hand corner of the cells. The
grip is a black square.

5. Drag the grip down to the end of the column by holding your left mouse button down, and
then when you are at the bottom of the column release the left mouse button.

This automatically populates the fields in numeric order with the sequence that was provided.

6. Typein a CSldivision number, Unit Cost 1, Unit Cost 2 and Unit of Measure. Use 0's for
the unit costs and a unit of measure of EA.

The CSI division number indicates where the import goes when imported into the Quantity
Takeoff database. The unit costs need to be modified after the plant sizes have been established.

7. Highlight all of the columns excluding the Description and Item ID number.

8. Select the grip, hold the left mouse button down and drag the grip to the bottom of the
column.

This automatically populates all of the cells in those columns with the same information.



Example:

». Microsoft Excel - Test 1.nam

B e Edt Yew Insert Pormat Jook [ats Window Help =1 x|
D SERY iR o-- A% = L5 DS T
..ﬁna = 10 'llfﬂ ';IIE ﬂ“-'ﬁﬂq’ﬂ _1¢'ﬁ'
F20 =| -'_ _ _
A B = ] E F | ] =

1 Die=cription ham b 51 Plarting size Unid cost 1 Linit cosxt 2 Uinit of measurs =
| 2 A gcigntific Mame 10000010 & 0 0 ea

3 _-Il]'.-;tlla gr;lnrlll'lnra 100000210 [ n| 0 ma

4  Ahes armabilis 10000=0 & u] 0 ea

& Abies concolos 10000040 & ] 0 ea

B Abicg grandis 0monsn 5 1] 0 ea

¥ Abios lasiocans 0mn:sn 5 1] Oea
| B Abizs magnifica 0000 & 0 AT

2 Abies procera 000000 & 0 0 ra

0 Acacia consticla D000=0 & u] 0 &a

1 Acacia famesiana 10000100 & 1] 0 ea

12 Acacia gregagi 1000110 5 1] 0 ea

13 Acacia redolens MMz 5 1] 0 ea
| 14 Acacia stenophylla 10000130 & 0 0 ea

15 Acalypha wilkesiana 10000140 & 0 0 na

16

17

18

19

20 1

21

2 .
[ A [BTH vest 1 4] o
Rasdy 1 T [ e e [ O

Inserting Planting sizes for each plant

Using the same techniques above, you will add all of the planting sizes for each plant.

1. Highlight the number of rows underneath the first plant name needed to accommodate the

number of plant sizes.
2. Right mouse click and select Insert.
This places the necessary empty cells.

3. Highlight the cell with the plant name.

4. Select the grip in the lower right hand corner of the cell and drag it down to the end of the

empty cells.

This copies the name to all of the cells.

5. In the empty cell below the Item ID, type in the next number in sequence (e.g., if the Item ID

number in the first cell is 10000010, type in 10000011).

6. Highlight the two Item ID cells.



7. Select the grip and drag down to the end of the empty cells.
This populates the cells with the numbering sequence that you provide.
8. Typen the first plant size, e.g. 1 gallon.

9. Highlight the cells containing the CSlI, Planting Size, Unit Cost 1, Unit Cost 2 and Unit of
Measure in the row containing the original plant size.

10. Select the grip and drag down to the end of the empty row.
This automatically copies the information from the original cells to the empty cells.
11. Change all of the costs to the desired numbers.

Finished example:

NEE SRy BRI v~ @@= 42/ % 9P T

Aria -0 - B USEE=EE8%, 9% -2-A
D11 | =|
A, | B |c] D | E | F | G |
1 |Description ltermn Id 351 Planting size |Unit cost 1 Unit cost 2 Unit of measure
2 |A scientific Mame 100000100 511 gallan 0 Olea
3 |A scientific Name 10000011 B 2 gallon 0 O ea
4 | A scientific Marme 10000012 7|3 gallon 0 O ea
5 |A scientific MNarme 10000013 84 gallon 0 O ea
B |A scientific MName 10000014 915 gallon 0 Oea
7 |A scientific MName 100000150 1016 gallon 0 O ea
g |Abelia grandiflara 1oooooz20; 5 0 Olea
3 |Abies amabilis 10000030, 5 0 0 ea
1L Akirs rnncnlne mnnnnant & Mn MNera

12. Follow the above steps with each of the plants in the list.
Importing into Quantity Takeoff
1. From the File pull-down menu, select Save as.
You are prompted to select a file name and location for this file.
2. Change the file of type to *.csv.
3. Typein aname and click on Save.
4. Launch Eagle Point.
5. From the main Eagle Point tool bar select Products > Quantity Takeoff.

6. In Quantity Takeoff, select Database > Import.
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File To lmport: I

File Type: IE:::mma Separated File [*.cav)

— Import Links
5] Dfisinr | ¥ (it st 2: | ¥l
[Eerm [ I j Siftermate | L I j
| = e I j Ehase Eade; I j
8 e 8 = = I j [Fenm [Eade; I j
=]

N e o I

Lo 1

Cancel |

7. Change the File Type to *.csv.
8. Click on Browse and find the file that was exported from Excel.

9. Change each of the Import options to the correct header, e.g. change the CSl division
number to CSI from the drop list. Do this for each of the import fields.

QTO Import |

File To Import: IE:'\'W'I MM TYPROFILES \StudentsD esktopiTest.cav Browse |

=~

File Type: IE:::mma Separated File [*.cav)

— Impart Links

CS! Divisior: |5

[tem 1D IItem Id

Dezcription; IDESCfiptiDn

Unit of kMeazure; ILInit of measure

Lef Lef L e e

Unit Cost 1: ILlnit ozt 1

it Cost 2: ILlnit cozt 2

Alternate 10 IF'Ianting zize

Phaze Code; I <Mones

Lef L e Lo

[tem Code; I <Miones

[ o |

Cancel

10. Click on OK.

If there are any errors a dialog box will display with the error highlighted in red. Make the

necessary changes and try the import again. When the import is complete, a dialog box displays

the number of records successfully imported.

11. Click on Done.

12. Double-check the import in the Quantity Takeoff database.
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